Linboost.org

Les Tutoriaux de Linboost.org

Flash Player
Pour les pressés, il y a le rpm ici.
Pour ceux qui aiment le faire eux-même, voici la métode:
1) Il vous faut télécharger le install_flash_player_6_linux.tar.gz qui se trouve:
http://www.macromedia.com/shockwave/download/download.cgi?P1_Prod_Version=ShockwaveFlash&P2;_Platform=Linux&P3;_Browser_Version=Netscape4

2) Vous devez avoir un répertoire rpmbuild de créer:
[[email protected] tchung]$ cd ~
[[email protected] tchung]$ cp -a /usr/src/redhat/ rpmbuild
[[email protected] tchung]$ echo '%_topdir %(echo $HOME)/rpmbuild' >> .rpmmacros
Il faut déplacer le tarball dans rpmbuild/SOURCES
[[email protected] download]$ mv install_flash_player_6_linux.tar.gz ~/rpmbuild/SOURCES/

3) Une bonne idée serait de mettre le EULA aussi:
http://fedoranews.org/tchung/flashplayer/EULA
[[email protected] download]$ mv EULA ~/rpmbuild/SOURCES/

4) Télécharger le fichier spec ( http://fedoranews.org/tchung/flashplayer/flash-plugin.spec ) et le mettre dans rpmbuild/SPECS
[[email protected] download]$ mv flash-plugin.spec ~/rpmbuild/SPECS/

5) Maintenant, on crée le rpm binaire et source:
[[email protected] download]$ cd ~/rpmbuild/SPECS/
[[email protected] SPECS]$ ls
flash-plugin.spec
[[email protected] SPECS]$ rpmbuild -ba flash-plugin.spec

6) Pour terminer, installer le rpm avec une commande sudo:
sudo rpm -Uvh /home/tchung/rpmbuild/RPMS/i386/flash-plugin-6.0.79-fc1.i386.rpm
Si vous avez un message d'erreur du genre:
error: Failed dependencies:
compat-libstdc++ >= 7.3-2.96.118 is needed by flash-plugin-6.0.79-fc1
Prenez votre cd 3 de Fedora et installez le package (par sécurité, le devel aussi) et ré-exécutez la commande.

7) Pour vérifier si vous avez bien votre plugin installé, il suffit d'ouvrir Mozilla, puis Help, about Plugins et là, vous devriez voir:
ceci

Valid HTML 4.01! Valid CSS!

Apache Mysql PhpMyAdmin Linux

Copyright © 2004 by Linboost.org. All Rights Reserved, All the comments and Marks are property of their authors.